MACD彩蛋 源码,贴图,解除时间限制

 2022-05-09    通达信指标网  

 {公式名称: MACD彩蛋

公式描述: 
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无
 
参数精灵:无
用法注释:无
公式源码:}
 
VAR1:=1;
DIF:IF(VAR1=1,MACD.DIF,0),LINETHICK2;
DEA:IF(VAR1=1,MACD.DEA,0);
DRAWTEXT_FIX(VAR1=0,0,0.01,0,27),COLORMAGENTA;
MACD:(DIF-DEA)*2,COLORSTICK;
DRAWICON(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1) AND DIF>0 AND DIF>DEA,DIF*1.1,2),COLORGREEN;
DRAWICON(CROSS(DEA,DIF) AND DIF>0,DIF,37),COLORGREEN;
DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,DIF*1.1,1),COLORRED;
DRAWICON(CROSS(DIF,DEA) AND DIF<0,DIF,36),COLORRED;
VAR2:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
VAR3:=LLVBARS(MACD,VAR2+20);
VAR4:=IF(VAR3>VAR2,REF(MACD,VAR3),0);
VAR5:=MACD<0 AND MACD>VAR4 AND LOW=LLV(LOW,VAR2+20) AND VAR4<0;
VAR6:=REF(VAR5,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,VAR3)<0 AND MACD<0;
低背:DRAWLINE(VAR4=VAR3,MACD,VAR6,MACD,0),COLORRED,LINETHICK2;
DRAWICON(VAR6,MACD*1.2,26);
VAR7:=HHVBARS(MACD,VAR2+20);
VAR8:=IF(VAR7>VAR2,REF(MACD,VAR7),0);
VAR9:=MACD>0 AND MACD<VAR8 AND HIGH=HHV(HIGH,VAR2+20) AND VAR8>0;
VAR10:=REF(VAR9,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,VAR7)>0;
顶背:DRAWLINE(VAR8=VAR7,MACD,VAR10,MACD,0),COLORGREEN,LINETHICK2;
DRAWICON(VAR10,MACD*1.2,15);
VAR11:=CLOSE/MA(CLOSE,40)*100<78;
VAR12:=CLOSE/MA(CLOSE,60)*100<74;
VAR13:=HIGH>LOW*1.051;
VAR14:=VAR13 AND COUNT(VAR13,5)>1;
VAR15:=IF(VAR14 AND (VAR11 OR VAR12),2,0);
VAR16:=CLOSE/REF(CLOSE,25)<=1.1;
VAR17:=SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<15;
VAR18:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
VAR19:=SMA(VAR18,2,1);
VAR20:=SMA(VAR19,2,1);
VAR21:=IF(VAR19>REF(VAR19,1) AND REF(VAR19,1)<REF(VAR19,2) AND VAR19<23,1.5,0);
抄底:VAR16 AND VAR15 AND VAR17 AND VAR21 AND VAR1=1,COLORWHITE;
VAR22:=100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8));
VAR23:=MA(CLOSE,5);
VAR24:=IF(CLOSE>SAR(10,2,20),1,0);
VAR25:=IF(CLOSE<SAR(10,2,20),(-1),0);
VAR26:=ATAN((VAR23/REF(VAR23,1)-1)*100)*180/3.1416;
VAR27:=IF(VAR26>30,1,0);
VAR28:=IF(VAR26<(-30),(-1),0);
VAR29:=VAR24+VAR27+VAR25+VAR28;
IF(VAR29<(-1) OR VAR22<25.01,DIF,DRAWNULL),COLORGREEN,LINETHICK2;

IF(VAR22>74.989998 OR VAR29>0,DIF,DRAWNULL),COLORRED,LINETHICK2;


  •  标签:  

原文链接:http://www.tdxzb.com/?id=288

本文版权:如无特别标注,本站文章均为原创。


联系客服