缠论多空画线飘带,自动划线公式(通达信公式 副图 源码 测试图)

 2022-05-13    通达信指标网  

缠论 的公式,多空画线飘带,自动划线

多空方向一目了然,就画线有未来,飘带没有未来不漂移。

SJ:=1;
{减4天,上方时间提前2天,30号到期28号提示}

DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26))*4.1;
DEA:=EMA(DIFF,9)*SJ; 
MA601:=MA(C,60)*SJ;
DKB:MA601+DIFF,COLORWHITE,LINETHICK1;
DKA:MA601+DEA,COLORYELLOW,LINETHICK1;
IF(DKB>=DKA,DKB,DKA),COLOR408080; 
IF(DKB<DKA,DKB,DKA),COLORFFFF00; 
DRAWBAND(DKB,RGB(255,51,87),DKA,RGB(0,185,0));

顶周期:=20;
底周期:=20;
上内:=LLVBARS(H,顶周期);
上外:=LLVBARS(L,顶周期);
下内:=HHVBARS(L,底周期);
下外:=HHVBARS(H,底周期);
上力度:=HHV(L,上内+1)>LLV(H,上内+1);
下力度:=HHV(L,下内+1)>LLV(H,下内+1);
上包含:=COUNT(L>=REF(L,1),上外)>2 AND COUNT(H>=REF(H,1),上内)>2 ;
下包含:=COUNT(H<=REF(H,1),下外)>2 AND COUNT(L<=REF(L,1),下内)>2 ; 
顶0:= 上力度 AND 上包含 AND 上外>3;
底0:= 下力度 AND 下包含 AND 下外>3;
顶:=顶0 AND H=HHV(H,BARSLAST(底0)) AND BARSLAST(底0)>3;
底:=底0 AND L=LLV(L,BARSLAST(顶0)) AND BARSLAST(顶0)>3;
DRAWLINE(CROSS(BACKSET(顶,BARSLAST(底)+1),0.5) ,L,CROSS(BACKSET(底,BARSLAST(顶)+1),0.5),H,0),COLORRED,LINETHICK3;
DRAWLINE(CROSS(BACKSET(底,BARSLAST(顶)+1),0.5) ,H,CROSS(BACKSET(顶,BARSLAST(底)+1),0.5),L,0),COLORGREEN,LINETHICK2;


  •  标签:  

原文链接:http://www.tdxzb.com/?id=292

本文版权:如无特别标注,本站文章均为原创。


联系客服