龙虎榜主图,易鸣龙虎榜公式

 2022-05-13    通达信指标网  

 BOLL1:=MA(C,20);

顶部:=BOLL1+2*STD(CLOSE,20);
底部:=BOLL1-2*STD(CLOSE,20);
DRAWBAND(顶部,RGB(35,35,35),底部,RGB(25,25,25));
DRAWKLINE(H,O,L,C);
DRAWBAND(BOLL1,RGB(155,155,155),BOLL1,RGB(155,25,25));
布林线:IF(ISLASTBAR,BOLL1,DRAWNULL),COLORRED,CIRCLEDOT;
ZT:=C>=REF(C,1)*1.097 AND NOT(C>=REF(C,1)*1.097 AND C=O AND H=L) AND BARSCOUNT(CLOSE)>2; 
HS:=V/CAPITAL*100>=20 AND BARSCOUNT(CLOSE)>2;
振幅:(H-L)/REF(C,1)*100>15 AND BARSCOUNT(CLOSE)>2;
ZFPL:=C/REF(C,1)>1.08  AND NOT(C>=REF(C,1)*1.097 AND C=O AND H=L) AND BARSCOUNT(CLOSE)>2;
DFPL:=REF(C,1)/C<=1.08;
DRAWTEXT(ZT,H,'<---涨停'),COLORMAGENTA;
DRAWTEXT(HS,L*1.05,'<---换手20%'),COLORYELLOW;
DRAWTEXT(振幅,L*1.02,'<---震幅15%'),COLORGRAY;
DRAWTEXT(ZFPL,H*0.98,'<---涨幅7%'),COLORRED;
DRAWTEXT(NOT(DFPL) AND BARSCOUNT(CLOSE)>2,L,'<---跌幅7%'),COLORGREEN;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,' ');

DRAWTEXT_FIX(ISLASTBAR,0,5,0,STRCAT(Z4,GNBLOCK)),COLORYELLOW;


  •  标签:  

原文链接:http://www.tdxzb.com/?id=295

本文版权:如无特别标注,本站文章均为原创。


联系客服