竞价研究(源码,副图,通达信,贴图)

 2022-09-21    通达信指标网  

为实现一位朋友多项复杂的与竞价信息有关的分析选股要求,试着一步一步开发实现(因为复杂系统的开发就是成功一步再走下一步的)。
请有兴趣者注意:这里公布的”竞价研究“-----只是初步成果,看个雏形,还要在短期内花时间进一步作改进!
其中:开盘第一笔量和开盘第一笔主买,那位朋友给的公式是一样的,似乎有问题,请那位朋友校对。
希望最终能实现你的期盼,并将最终结果与大家分享!

SUMV:=SUM(V,0); 

竞价量:REF(SUMV,BARSLAST(TIME2<093000)),NODRAW; 
开盘一分钟量:REF(SUMV,BARSLAST(TIME2<=093100)),NODRAW; {竞价量}


SUMBUYV:=SUM(BUYVOL,0); {返回外盘即DYNAINFO(23)}
竞价主买:REF(SUMBUYV,BARSLAST(TIME2<093000)),NODRAW;
开盘一分主买:REF(SUMBUYV,BARSLAST(TIME2<=093100)),NODRAW;
{竞价主买,即外盘量}


开盘第一笔量:REF(V,BARSSINCE(TIME2>=093000)),NODRAW;
开盘第一笔主买:REF(V,BARSSINCE(TIME2>=093000)),NODRAW;
{第一次V不为0到现在的周期数}


竞价换手:竞价量/CAPITAL * 100,NODRAW;
竞价主买占比: 竞价主买/竞价量 * 100,NODRAW;
开盘主买占比: 开盘一分主买/开盘一分钟量 * 100,NODRAW;
开盘换手:开盘一分钟量/ CAPITAL * 100,NODRAW;


{今日竞价数据显示}
DRAWTEXT_FIX(1,0.05,0.1,0,'【日期:                        】'), COLORGREEN,LINETHICK2; 
DRAWTEXT_FIX(1,0.11,0.1,0,CON2STR(DATE+19000000,0)),COLORMAGENTA,LINETHICK2;


DRAWTEXT_FIX(1,0.25,0.1,0,'今日竞价数据'),COLORYELLOW,LINETHICK3;


DRAWTEXT_FIX(1,0.2,0.25,0,'竞价量:             '),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.31,0.25,0,CON2STR(竞价量,2)),COLORMAGENTA,LINETHICK2;


DRAWTEXT_FIX(1,0.2,0.40,0,'竞价主买量:          '),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.31,0.40,0,CON2STR(竞价主买,2)),COLORMAGENTA,LINETHICK2;


DRAWTEXT_FIX(1,0.2,0.55,0,'竞价换手:           '),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.31,0.55,0,CON2STR(竞价换手,2)),COLORMAGENTA,LINETHICK2;


DRAWTEXT_FIX(1,0.2,0.70,0,'竞价主买占比:   '),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.31,0.70,0,CON2STR(竞价主买占比,2)),COLORMAGENTA,LINETHICK2;
{今日开盘数据}
DRAWTEXT_FIX(1,0.55,0.1,0,'今日开盘数据'),COLORYELLOW,LINETHICK3;


DRAWTEXT_FIX(1,0.50,0.25,0,'开盘一分钟量:             '),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.61,0.25,0,CON2STR(开盘一分钟量,2)),COLORMAGENTA,LINETHICK2;


DRAWTEXT_FIX(1,0.50,0.40,0,'开盘一分主买:          '),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.61,0.40,0,CON2STR(开盘一分主买,2)),COLORMAGENTA,LINETHICK2;


DRAWTEXT_FIX(1,0.50,0.55,0,'开盘换手:           '),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.61,0.55,0,CON2STR(开盘换手,2)),COLORMAGENTA,LINETHICK2;


DRAWTEXT_FIX(1,0.50,0.70,0,'开盘主买占比:   '),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.61,0.70,0,CON2STR(开盘主买占比,2)),COLORMAGENTA,LINETHICK2;


DRAWTEXT_FIX(1,0.75,0.25,0,'开盘第一笔量:             '),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.86,0.25,0,CON2STR(开盘第一笔量,2)),COLORMAGENTA,LINETHICK2;


DRAWTEXT_FIX(1,0.75,0.40,0,'开盘第一笔主买:          '),COLORWHITE,LINETHICK2;

DRAWTEXT_FIX(1,0.86,0.40,0,CON2STR(开盘第一笔主买,2)),COLORMAGENTA,LINETHICK2;


  •  标签:  

原文链接:https://www.tdxzb.com/?id=594

本文版权:如无特别标注,本站文章均为原创。


服务热线

18020657357

微信客服

微信客服